aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2023-08-29 16:22:21 +0200
committerThomas White <taw@physics.org>2023-08-29 16:22:21 +0200
commitb50c4f1609e0c030bf6574cf1fdc217e85ed3c33 (patch)
tree16b9565baf2d850a5da5e4cdb8f7747d7ba5c64f /meson.build
parent65283ba88efca2a85e96fc1ac2128d3d999f8fa2 (diff)
Meson: Simplify Millepede build system
There are no dependencies, only a subproject via wrap.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 19266444..11382f1d 100644
--- a/meson.build
+++ b/meson.build
@@ -162,6 +162,10 @@ executable('align_detector',
install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
+# Get 'pede' from the subproject (needed for align_detector)
+millepede_proj = subproject('millepede')
+pede_exe = millepede_proj.get_variable('pede')
+
# adjust_detector
adjust_detector = executable('adjust_detector',
['src/adjust_detector.c', versionc],