aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2023-09-01 17:18:51 +0200
committerThomas White <taw@physics.org>2023-09-01 17:18:51 +0200
commitd170ca538a234ea0de20722c5453d2cd7d4e0ef8 (patch)
tree7d1ee3b16d98e0661d68647b3b1ed37487ecba99 /meson.build
parent3f6dbaccbc7c8f4950fcbcd5498794286a981c48 (diff)
Manual page for adjust_detector (using Pandoc)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 11382f1d..172085c5 100644
--- a/meson.build
+++ b/meson.build
@@ -278,6 +278,21 @@ subdir('tests')
# ************************ Manual pages ************************
+
+pandoc = find_program('pandoc', required: false)
+
+pandoc_pages = ['adjust_detector.1.md']
+
+foreach page : pandoc_pages
+ custom_target(page,
+ input: join_paths('doc/man', page),
+ output: '@BASENAME@',
+ command: [pandoc, '@INPUT@','-o', '@OUTPUT@',
+ '-s', '-f', 'markdown-smart', '-t', 'man'],
+ install: true,
+ install_dir: join_paths(get_option('mandir'), 'man1'))
+endforeach
+
install_man(['doc/man/ambigator.1',
'doc/man/cell_explorer.1',
'doc/man/cell_tool.1',