aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2023-09-18 16:59:01 +0200
committerThomas White <taw@physics.org>2023-09-18 16:59:01 +0200
commite720290743e536e8c05695d22c939cf433055336 (patch)
tree7b6e3de165cfd3d4b194a11c375d035ac6ff4270 /meson.build
parent1ae9a458265df2bae2a4d05089e83390ae30084a (diff)
Meson: Make Millepede subproject optional
This should help avoid confusion when people find they need a Fortran compiler.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 27fa4af0..24144f8d 100644
--- a/meson.build
+++ b/meson.build
@@ -163,7 +163,7 @@ executable('align_detector',
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
# Get 'pede' from the subproject (needed for align_detector)
-millepede_proj = subproject('millepede')
+millepede_proj = subproject('millepede', required: false)
pede_exe = millepede_proj.get_variable('pede')
# adjust_detector