aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2021-07-01 11:31:39 +0200
committerThomas White <taw@physics.org>2021-07-01 11:31:39 +0200
commitffbb75c869cc8197e3bfa5228252dd286a0e511b (patch)
tree2ab1410a996040a6ea9c94f35b0dca181db3dffd /meson.build
parentbcd15652350a86bc10ace2331ee57ef8aa2a52d9 (diff)
Meson: Fussiness
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build128
1 files changed, 65 insertions, 63 deletions
diff --git a/meson.build b/meson.build
index f07df9b6..b2a1f3fd 100644
--- a/meson.build
+++ b/meson.build
@@ -1,11 +1,11 @@
# Meson file for CrystFEL
project('crystfel', 'c',
- version : '0.9.1',
- license : 'GPL3+',
- meson_version : '>=0.50.0',
- default_options : ['buildtype=debugoptimized'])
+ version: '0.9.1',
+ license: 'GPL3+',
+ meson_version: '>=0.50.0',
+ default_options: ['buildtype=debugoptimized'])
-add_project_arguments('-DHAVE_CONFIG_H', language : 'c')
+add_project_arguments('-DHAVE_CONFIG_H', language: 'c')
versionc = vcs_tag(input: 'src/version.c.in',
output: 'version.c')
@@ -15,15 +15,15 @@ conf_data = configuration_data()
# Mandatory dependencies
cc = meson.get_compiler('c')
-mdep = cc.find_library('m', required : true)
-gsldep = dependency('gsl', required : true)
-zlibdep = dependency('zlib', required : true)
-pthreaddep = dependency('threads', required : true)
+mdep = cc.find_library('m', required: true)
+gsldep = dependency('gsl', required: true)
+zlibdep = dependency('zlib', required: true)
+pthreaddep = dependency('threads', required: true)
# Try via pkg-config first:
-slurmdep = dependency('slurm', required : false)
+slurmdep = dependency('slurm', required: false)
if not slurmdep.found()
- slurmdep = cc.find_library('slurm', required : false)
+ slurmdep = cc.find_library('slurm', required: false)
endif
if slurmdep.found()
@@ -31,40 +31,40 @@ if slurmdep.found()
endif
# Find HDF5 using inbuilt Meson methods. Requires Meson >= 0.50.0
-hdf5dep = dependency('hdf5', language : 'c', required : true)
+hdf5dep = dependency('hdf5', language: 'c', required: true)
# Request HDF5 1.10-style API
-add_project_arguments('-DH5_USE_110_API', language : 'c')
-add_project_arguments('-DH5O_GET_INFO_BY_IDX1', language : 'c')
+add_project_arguments('-DH5_USE_110_API', language: 'c')
+add_project_arguments('-DH5O_GET_INFO_BY_IDX1', language: 'c')
# "Optional" dependencies
-fftwdep = dependency('fftw3', required : false)
+fftwdep = dependency('fftw3', required: false)
if fftwdep.found()
conf_data.set10('HAVE_FFTW', 1)
endif
-gtkdep = dependency('gtk+-3.0', required : false)
+gtkdep = dependency('gtk+-3.0', required: false)
if gtkdep.found()
- add_project_arguments('-Wno-deprecated-declarations', language : 'c')
+ add_project_arguments('-Wno-deprecated-declarations', language: 'c')
conf_data.set10('HAVE_GTK', 1)
endif
-gdkdep = dependency('gdk-3.0', required : false)
+gdkdep = dependency('gdk-3.0', required: false)
if gdkdep.found()
conf_data.set10('HAVE_GDK', 1)
endif
-gdkpixbufdep = dependency('gdk-pixbuf-2.0', required : false)
+gdkpixbufdep = dependency('gdk-pixbuf-2.0', required: false)
if gdkpixbufdep.found()
conf_data.set10('HAVE_GDKPIXBUF', 1)
endif
-cairodep = dependency('cairo', required : false)
+cairodep = dependency('cairo', required: false)
if cairodep.found()
conf_data.set10('HAVE_CAIRO', 1)
endif
-opencldep = dependency('OpenCL', required : false)
+opencldep = dependency('OpenCL', required: false)
if opencldep.found()
conf_data.set10('HAVE_OPENCL', 1)
endif
@@ -72,12 +72,12 @@ if cc.has_header('CL/cl.h')
conf_data.set10('HAVE_CL_CL_H', 1)
endif
-zmqdep = dependency('libzmq', required : false)
+zmqdep = dependency('libzmq', required: false)
if zmqdep.found()
conf_data.set10('HAVE_ZMQ', 1)
endif
-if cc.has_function('clock_gettime', prefix : '#include <time.h>')
+if cc.has_function('clock_gettime', prefix: '#include <time.h>')
conf_data.set10('HAVE_CLOCK_GETTIME', 1)
endif
@@ -87,58 +87,58 @@ subdir('libcrystfel')
# ************************ The programs ************************
-configure_file(input : 'config.h.in',
- output : 'config.h',
- configuration : conf_data)
+configure_file(input: 'config.h.in',
+ output: 'config.h',
+ configuration: conf_data)
conf_inc = include_directories('.')
# cell_tool
executable('cell_tool',
['src/cell_tool.c', versionc],
- dependencies : [mdep, libcrystfeldep],
- install : true,
+ dependencies: [mdep, libcrystfeldep],
+ install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
# partial_sim
executable('partial_sim',
['src/partial_sim.c', versionc],
- dependencies : [mdep, libcrystfeldep, gsldep, pthreaddep],
- install : true,
+ dependencies: [mdep, libcrystfeldep, gsldep, pthreaddep],
+ install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
# process_hkl
process_hkl = executable('process_hkl',
['src/process_hkl.c', versionc],
- dependencies : [mdep, libcrystfeldep],
- install : true,
+ dependencies: [mdep, libcrystfeldep],
+ install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
# list_events
executable('list_events',
['src/list_events.c', versionc],
- dependencies : [mdep, libcrystfeldep],
- install : true,
+ dependencies: [mdep, libcrystfeldep],
+ install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
# get_hkl
executable('get_hkl',
['src/get_hkl.c', versionc],
- dependencies : [mdep, libcrystfeldep, gsldep],
- install : true,
+ dependencies: [mdep, libcrystfeldep, gsldep],
+ install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
# compare_hkl
executable('compare_hkl',
['src/compare_hkl.c', versionc],
- dependencies : [mdep, libcrystfeldep, gsldep],
- install : true,
+ dependencies: [mdep, libcrystfeldep, gsldep],
+ install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
# check_hkl
executable('check_hkl',
['src/check_hkl.c', versionc],
- dependencies : [mdep, libcrystfeldep, gsldep],
- install : true,
+ dependencies: [mdep, libcrystfeldep, gsldep],
+ install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
# partialator
@@ -149,22 +149,22 @@ partialator = executable('partialator',
'src/rejection.c',
'src/scaling.c',
versionc],
- dependencies : [mdep, libcrystfeldep, gsldep, pthreaddep],
- install : true,
+ dependencies: [mdep, libcrystfeldep, gsldep, pthreaddep],
+ install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
# ambigator
executable('ambigator',
['src/ambigator.c', versionc],
- dependencies : [mdep, libcrystfeldep, gsldep, hdf5dep],
- install : true,
+ dependencies: [mdep, libcrystfeldep, gsldep, hdf5dep],
+ install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
# whirligig
executable('whirligig',
['src/whirligig.c', versionc],
- dependencies : [mdep, libcrystfeldep],
- install : true,
+ dependencies: [mdep, libcrystfeldep],
+ install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
# indexamajig
@@ -176,24 +176,24 @@ if zmqdep.found()
endif
executable('indexamajig', indexamajig_sources,
- dependencies : [mdep, libcrystfeldep, gsldep, pthreaddep, zmqdep],
- install : true,
+ dependencies: [mdep, libcrystfeldep, gsldep, pthreaddep, zmqdep],
+ install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
# make_pixelmap
executable('make_pixelmap',
['src/make_pixelmap.c', versionc],
- dependencies : [mdep, libcrystfeldep, hdf5dep],
- install : true,
+ dependencies: [mdep, libcrystfeldep, hdf5dep],
+ install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
# geoptimiser
# FIXME: restore
#executable('geoptimiser',
# ['src/geoptimiser.c', 'src/hdfsee-render.c', versionc],
-# dependencies : [mdep, libcrystfeldep, gsldep, gdkpixbufdep, gdkdep],
-# install : true,
-# install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
+# dependencies: [mdep, libcrystfeldep, gsldep, gdkpixbufdep, gdkdep],
+# install: true,
+# install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
# CrystFEL GUI
if gtkdep.found()
@@ -221,8 +221,8 @@ if gtkdep.found()
executable('crystfel', gui_sources,
- dependencies : [mdep, libcrystfeldep, gtkdep, gsldep, slurmdep],
- install : true,
+ dependencies: [mdep, libcrystfeldep, gtkdep, gsldep, slurmdep],
+ install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
endif
@@ -230,16 +230,16 @@ endif
# render_hkl
executable('render_hkl',
['src/render_hkl.c', versionc],
- dependencies : [mdep, libcrystfeldep, cairodep, gsldep],
- install : true,
+ dependencies: [mdep, libcrystfeldep, cairodep, gsldep],
+ install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
# cell_explorer
if gtkdep.found()
executable('cell_explorer',
['src/cell_explorer.c', 'src/multihistogram.c', versionc],
- dependencies : [mdep, libcrystfeldep, gtkdep, gsldep],
- install : true,
+ dependencies: [mdep, libcrystfeldep, gtkdep, gsldep],
+ install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
endif
@@ -249,17 +249,19 @@ if opencldep.found()
pattern_sim_sources += ['src/diffraction-gpu.c', 'src/cl-utils.c']
endif
executable('pattern_sim', pattern_sim_sources,
- dependencies : [mdep, libcrystfeldep, gsldep, hdf5dep, opencldep],
- install : true,
+ dependencies: [mdep, libcrystfeldep, gsldep, hdf5dep, opencldep],
+ install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
# For testing (see tests/meson.build)
-simulation_bits = files(['src/diffraction.c', 'src/diffraction-gpu.c', 'src/cl-utils.c'])
+simulation_bits = files(['src/diffraction.c',
+ 'src/diffraction-gpu.c',
+ 'src/cl-utils.c'])
# ************************ Misc resources ************************
install_data(['data/crystfel.svg'],
- install_dir : get_option('datadir')+'/icons/hicolor/scalable/apps')
+ install_dir: get_option('datadir')+'/icons/hicolor/scalable/apps')
# ************************ Testing ************************