aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2009-11-12 12:06:06 +0100
committerThomas White <taw@physics.org>2009-11-12 12:06:06 +0100
commitc6b74b77b111c4e45b93ef9f02863dceafe0d047 (patch)
treed183f53a7e9aa6af3ccfa607eaac19dd3957f602 /src/Makefile.am
parentf09b0fc4da61d107dffc0d45489b769326fd8a08 (diff)
Sort out libraries and cflags
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3ab2d7f8..eca48660 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,6 @@
bin_PROGRAMS = pattern_sim
+AM_CFLAGS = -Wall -g @CFLAGS@
+
pattern_sim_SOURCES = main.c diffraction.c utils.c image.c cell.c hdf5-file.c
-pattern_sim_LDADD = @LIBS@ -lm -lgsl -lgslcblas
+pattern_sim_LDADD = @LIBS@