aboutsummaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2023-07-05 17:07:58 +0200
committerThomas White <taw@physics.org>2023-07-28 13:22:05 +0200
commit1857f41d235359d9ed6c018b63ccda63edba9d2f (patch)
treeb5396eda5822b9ff38dd48b743b7ef062e4e3e1c /tests/meson.build
parent25e4fc2a3719f2db74e760deb2edd50c82096f01 (diff)
Unify panel position gradient tests into one file
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build19
1 files changed, 11 insertions, 8 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 6388a680..16c8f3a1 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -96,16 +96,19 @@ exe = executable('prof2d_check',
test('prof2d_check', exe)
-# Refinement gradient checks
-gradient_tests = ['gradient_panel_x',
- 'gradient_cell_asx']
-
-foreach name : gradient_tests
- exe = executable(name,
- [''.join([name, '.c']),
+# Refinement gradient checks, part 1: panel positions
+panel_gradient_tests = [['gradient_panel_x', 'cnx', 'GPARAM_DET_TX'],
+ ['gradient_panel_y', 'cny', 'GPARAM_DET_TY'],
+ ['gradient_panel_z', 'cnz', 'GPARAM_DET_TZ']]
+
+foreach name : panel_gradient_tests
+ exe = executable(name[0],
+ ['gradient_panel_move.c',
'gradient_check_utils.c'],
+ c_args : ['-DTHING_TO_MOVE='+name[1],
+ '-DTEST_GPARAM='+name[2]],
dependencies : [libcrystfeldep, mdep, gsldep])
- test(name, exe)
+ test(name[0], exe)
endforeach