aboutsummaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2022-03-08 11:57:55 +0100
committerThomas White <taw@physics.org>2022-03-08 14:14:53 +0100
commit59e8a7ef447d0c8c56d33bfb7baf0010b5873fd7 (patch)
treec0f5551dd980b2ef56e3e56170046643ab874f62 /tests/meson.build
parenta40d7a356c3a71c83b9f0556f878aea1f607c0af (diff)
Add tests/stream_roundtrip
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index aa425707..0109ec9d 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -68,6 +68,12 @@ endforeach
# Less easy unit tests for libcrystfel functions
+exe = executable('stream_roundtrip',
+ ['stream_roundtrip.c'],
+ dependencies : [libcrystfeldep])
+test('stream_roundtrip', exe,
+ args: [files('stream_roundtrip.geom')])
+
exe = executable('stream_read',
['stream_read.c'],
dependencies : [libcrystfeldep])