aboutsummaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2023-06-22 16:16:01 +0200
committerThomas White <taw@physics.org>2023-07-28 13:22:05 +0200
commitd874916b10e9e5a40b96ca8f878c2a5f7cc60e35 (patch)
treedaf296047798bd94ad47e1b02d7acf4fd2fd3ef2 /tests/meson.build
parent4977cb7c384f9339037353f31abf0a6a8fd2aea7 (diff)
Simplified gradient test
prediction_gradient_check was out of control - it had option processing, as well as bugs of its own! This replaces it with something much simpler.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build14
1 files changed, 13 insertions, 1 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 917c59db..7fb6e83b 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -44,7 +44,6 @@ simple_tests = ['ambi_check',
'cell_check',
'centering_check',
'list_check',
- 'prediction_gradient_check',
'ring_check',
'symmetry_check',
'transformation_check',
@@ -96,6 +95,19 @@ exe = executable('prof2d_check',
dependencies : [libcrystfeldep, mdep, gsldep])
test('prof2d_check', exe)
+
+# Refinement gradient checks
+gradient_tests = ['gradient_panel_x']
+
+foreach name : gradient_tests
+ exe = executable(name,
+ [''.join([name, '.c']),
+ 'gradient_check_utils.c'],
+ dependencies : [libcrystfeldep, mdep, gsldep])
+ test(name, exe)
+endforeach
+
+
# Event enumeration tests
if hdf5dep.found()
ev_enum_tests = ['ev_enum1',