aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aea8e29d..1bf6ec7d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,7 @@
cmake_minimum_required(VERSION 3.6)
-project(crystfel VERSION 0.7.0 LANGUAGES C)
+set(CRYSTFEL_VERSION 0.7.0)
+set(CRYSTFEL_API_VERSION 10)
+project(crystfel VERSION ${CRYSTFEL_VERSION} LANGUAGES C)
include(GNUInstallDirs)