aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libcrystfel/Makefile.am')
-rw-r--r--libcrystfel/Makefile.am41
1 files changed, 0 insertions, 41 deletions
diff --git a/libcrystfel/Makefile.am b/libcrystfel/Makefile.am
deleted file mode 100644
index 1d24d353..00000000
--- a/libcrystfel/Makefile.am
+++ /dev/null
@@ -1,41 +0,0 @@
-lib_LTLIBRARIES = libcrystfel.la
-libcrystfel_la_LIBADD = ../lib/libgnu.la @LIBCRYSTFEL_LIBS@ $(PTY_LIB)
-libcrystfel_la_LDFLAGS = -version-info 10:0:0
-
-libcrystfel_la_SOURCES = src/reflist.c src/utils.c src/cell.c src/detector.c \
- src/thread-pool.c src/image.c src/hdf5-file.c \
- src/geometry.c src/statistics.c \
- src/symmetry.c src/stream.c src/peaks.c \
- src/reflist-utils.c src/filters.c \
- src/render.c src/index.c src/dirax.c src/mosflm.c \
- src/cell-utils.c src/integer_matrix.c src/crystal.c \
- src/xds.c src/integration.c src/predict-refine.c \
- src/histogram.c src/events.c src/felix.c \
- src/taketwo.c src/peakfinder8.c
-
-if HAVE_FFTW
-libcrystfel_la_SOURCES += src/asdf.c
-endif
-
-libcrystfel_la_includedir=$(includedir)/crystfel/
-
-libcrystfel_la_include_HEADERS = ${top_srcdir}/version.h \
- src/hdf5-file.h src/reflist.h src/symmetry.h \
- src/cell.h src/reflist-utils.h \
- src/thread-pool.h src/statistics.h \
- src/utils.h src/detector.h \
- src/geometry.h src/peaks.h src/stream.h \
- src/render.h src/index.h src/image.h \
- src/filters.h src/dirax.h src/mosflm.h \
- src/cell-utils.h \
- src/integer_matrix.h src/crystal.h \
- src/xds.h src/predict-refine.h \
- src/integration.h src/histogram.h \
- src/events.h src/asdf.h src/felix.h \
- src/taketwo.h src/peakfinder8.h
-
-AM_CPPFLAGS = -DDATADIR=\""$(datadir)"\" -I$(top_builddir)/lib -Wall
-AM_CPPFLAGS += -I$(top_srcdir)/lib @LIBCRYSTFEL_CFLAGS@
-
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = crystfel.pc