aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'libcrystfel/meson.build')
-rw-r--r--libcrystfel/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/libcrystfel/meson.build b/libcrystfel/meson.build
index 592ec22e..8897aaae 100644
--- a/libcrystfel/meson.build
+++ b/libcrystfel/meson.build
@@ -66,7 +66,10 @@ if ccp4dep.found()
conf_data.set10('HAVE_LIBCCP4', true)
endif
-msgpackdep = dependency('msgpack', required: false)
+msgpackdep = dependency('msgpack-c', required: false)
+if not msgpackdep.found()
+ msgpackdep = dependency('msgpack', required: false)
+endif
if msgpackdep.found()
conf_data.set10('HAVE_MSGPACK', true)
endif