aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am17
1 files changed, 1 insertions, 16 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7f7430ab..0d6162cb 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,7 +8,7 @@ endif
AM_CFLAGS = -Wall
AM_CPPFLAGS = -DDATADIR=\""$(datadir)"\" -I$(top_builddir)/lib -I$(top_srcdir)/lib
-LDADD = lib/libgnu.a
+LDADD = $(top_builddir)/lib/libgnu.a
pattern_sim_SOURCES = pattern_sim.c diffraction.c utils.c image.c cell.c \
hdf5-file.c detector.c sfac.c peaks.c reflections.c \
@@ -17,17 +17,13 @@ if HAVE_OPENCL
pattern_sim_SOURCES += diffraction-gpu.c cl-utils.c
endif
-pattern_sim_LDADD = @LIBS@
-
process_hkl_SOURCES = process_hkl.c sfac.c statistics.c cell.c utils.c \
reflections.c symmetry.c stream.c beam-parameters.c
-process_hkl_LDADD = @LIBS@
indexamajig_SOURCES = indexamajig.c hdf5-file.c utils.c cell.c image.c \
peaks.c index.c filters.c diffraction.c detector.c \
sfac.c dirax.c mosflm.c reflections.c templates.c \
symmetry.c geometry.c thread-pool.c beam-parameters.c
-indexamajig_LDADD = @LIBS@
if HAVE_OPENCL
indexamajig_SOURCES += diffraction-gpu.c cl-utils.c
endif
@@ -36,52 +32,41 @@ endif
if HAVE_GTK
hdfsee_SOURCES = hdfsee.c displaywindow.c render.c hdf5-file.c utils.c image.c \
filters.c
-hdfsee_LDADD = @LIBS@
endif
get_hkl_SOURCES = get_hkl.c sfac.c cell.c utils.c reflections.c symmetry.c \
beam-parameters.c
-get_hkl_LDADD = @LIBS@
compare_hkl_SOURCES = compare_hkl.c sfac.c cell.c utils.c reflections.c \
statistics.c symmetry.c
-compare_hkl_LDADD = @LIBS@
check_hkl_SOURCES = check_hkl.c sfac.c cell.c utils.c reflections.c \
statistics.c symmetry.c
-check_hkl_LDADD = @LIBS@
powder_plot_SOURCES = powder_plot.c cell.c utils.c image.c hdf5-file.c \
detector.c
-powder_plot_LDADD = @LIBS@
render_hkl_SOURCES = render_hkl.c cell.c reflections.c utils.c povray.c \
symmetry.c render.c hdf5-file.c image.c filters.c
-render_hkl_LDADD = @LIBS@
calibrate_detector_SOURCES = calibrate_detector.c utils.c hdf5-file.c image.c \
filters.c peaks.c detector.c cell.c thread-pool.c
-calibrate_detector_LDADD = @LIBS@
facetron_SOURCES = facetron.c cell.c hdf5-file.c utils.c detector.c peaks.c \
image.c geometry.c reflections.c stream.c thread-pool.c \
beam-parameters.c symmetry.c post-refinement.c hrs-scaling.c
-facetron_LDADD = @LIBS@
if HAVE_CAIRO
cubeit_SOURCES = cubeit.c cell.c hdf5-file.c utils.c detector.c render.c \
filters.c image.c symmetry.c stream.c thread-pool.c
-cubeit_LDADD = @LIBS@
endif
reintegrate_SOURCES = reintegrate.c cell.c hdf5-file.c utils.c detector.c \
peaks.c image.c stream.c \
index.c dirax.c mosflm.c templates.c geometry.c \
symmetry.c thread-pool.c
-reintegrate_LDADD = @LIBS@
estimate_background_SOURCES = estimate_background.c stream.c utils.c cell.c
-estimate_background_LDADD = @LIBS@
INCLUDES = "-I$(top_srcdir)/data"