aboutsummaryrefslogtreecommitdiff
path: root/plugin/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/test/Makefile.am')
-rw-r--r--plugin/test/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/plugin/test/Makefile.am b/plugin/test/Makefile.am
new file mode 100644
index 00000000..f7ec8ef7
--- /dev/null
+++ b/plugin/test/Makefile.am
@@ -0,0 +1,18 @@
+libdir = $(plugindir)
+
+lib_LTLIBRARIES = test.la
+
+test_la_SOURCES = test.c test.h
+test_la_LDFLAGS = -module -no-undefined -avoid-version
+
+INCLUDES = \
+ $(GTK_CFLAGS) \
+ -I$(includedir) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/libsylph \
+ -I$(top_srcdir)/src
+
+test_la_LIBADD = \
+ $(GTK_LIBS) \
+ $(top_srcdir)/src/libsylpheed-plugin-0.la \
+ $(top_srcdir)/libsylph/libsylph-0.la