aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2020-08-04 17:56:07 +0200
committerThomas White <taw@physics.org>2020-08-04 17:56:07 +0200
commitee5e7f49c4c582651d1c3760f204ac861864c9d5 (patch)
tree4afd939ebe2a739fd02b183a68803086d655a958 /CMakeLists.txt
parentf9d454ae2a5c2c3ac2d7fc7161a1f02fc87da612 (diff)
Convert pattern_sim to DataTemplate
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt35
1 files changed, 17 insertions, 18 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ced47030..7168ab43 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -190,24 +190,23 @@ list(APPEND CRYSTFEL_EXECUTABLES partial_sim)
# ----------------------------------------------------------------------
# pattern_sim
-# FIXME: Restore!
-#set(PATTERN_SIM_SOURCES src/pattern_sim.c src/diffraction.c)
-#
-#if(HAVE_OPENCL)
-# set(PATTERN_SIM_OPENCL_SOURCES src/cl-utils.c src/diffraction-gpu.c)
-#endif(HAVE_OPENCL)
-#
-#add_executable(pattern_sim ${PATTERN_SIM_SOURCES} ${PATTERN_SIM_OPENCL_SOURCES}
-# ${CMAKE_CURRENT_BINARY_DIR}/version.c)
-#target_include_directories(pattern_sim PRIVATE ${COMMON_INCLUDES})
-#target_link_libraries(pattern_sim ${COMMON_LIBRARIES} ${HDF5_C_LIBRARIES})
-#
-#if(HAVE_OPENCL)
-# target_include_directories(pattern_sim PRIVATE ${OpenCL_INCLUDE_DIRS})
-# target_link_libraries(pattern_sim ${OpenCL_LIBRARIES})
-#endif(HAVE_OPENCL)
-#
-#list(APPEND CRYSTFEL_EXECUTABLES pattern_sim)
+set(PATTERN_SIM_SOURCES src/pattern_sim.c src/diffraction.c)
+
+if(HAVE_OPENCL)
+ set(PATTERN_SIM_OPENCL_SOURCES src/cl-utils.c src/diffraction-gpu.c)
+endif(HAVE_OPENCL)
+
+add_executable(pattern_sim ${PATTERN_SIM_SOURCES} ${PATTERN_SIM_OPENCL_SOURCES}
+ ${CMAKE_CURRENT_BINARY_DIR}/version.c)
+target_include_directories(pattern_sim PRIVATE ${COMMON_INCLUDES})
+target_link_libraries(pattern_sim ${COMMON_LIBRARIES} ${HDF5_C_LIBRARIES})
+
+if(HAVE_OPENCL)
+ target_include_directories(pattern_sim PRIVATE ${OpenCL_INCLUDE_DIRS})
+ target_link_libraries(pattern_sim ${OpenCL_LIBRARIES})
+endif(HAVE_OPENCL)
+
+list(APPEND CRYSTFEL_EXECUTABLES pattern_sim)
# ----------------------------------------------------------------------
# cell_explorer