aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2023-12-19 11:58:53 +0100
committerThomas White <taw@physics.org>2023-12-19 11:58:53 +0100
commit28ecd688c994dce0bb66856ca16ada7d19c0d1ed (patch)
tree8aa07ce9f123380f7645f838a5f2168ccc3cb855 /meson.build
parentbc1dc265d43b189a954d08573ba1cf2dc2ee42d3 (diff)
Meson: Move crystfel_geometry.5 inside check for Pandoc
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 9 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index b30de9c4..248a75fa 100644
--- a/meson.build
+++ b/meson.build
@@ -294,15 +294,16 @@ if pandoc.found()
install: true,
install_dir: join_paths(get_option('mandir'), 'man1'))
endforeach
-endif
-custom_target('crystfel_geometry.5.md',
- input: 'doc/man/crystfel_geometry.5.md',
- output: 'crystfel_geometry.5',
- command: [pandoc, '@INPUT@','-o', '@OUTPUT@',
- '-s', '-f', 'markdown-smart', '-t', 'man'],
- install: true,
- install_dir: join_paths(get_option('mandir'), 'man5'))
+ custom_target('crystfel_geometry.5.md',
+ input: 'doc/man/crystfel_geometry.5.md',
+ output: 'crystfel_geometry.5',
+ command: [pandoc, '@INPUT@','-o', '@OUTPUT@',
+ '-s', '-f', 'markdown-smart', '-t', 'man'],
+ install: true,
+ install_dir: join_paths(get_option('mandir'), 'man5'))
+
+endif
install_man(['doc/man/ambigator.1',
'doc/man/cell_explorer.1',