aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNicholas Devenish <ndevenish@gmail.com>2021-08-17 14:58:37 +0100
committerThomas White <taw@physics.org>2021-08-19 17:55:47 +0200
commit5a54731eeb00ff9729b087bb801c50684417cacd (patch)
tree6a3c27851ccba8338ac8c0cc591674e12173138d /meson.build
parent8478dff2562b4fc2ff62239c322f4ecf4b5d0e1e (diff)
Search for OpenCL header with OpenCL
Previously, this was searching for OpenCL, and then trying to use the OpenCL header from only system locations.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 04c7cc2b..841e65cd 100644
--- a/meson.build
+++ b/meson.build
@@ -72,7 +72,7 @@ opencldep = dependency('OpenCL', required: false)
if opencldep.found()
conf_data.set10('HAVE_OPENCL', 1)
endif
-if cc.has_header('CL/cl.h')
+if cc.has_header('CL/cl.h', dependencies: opencldep)
conf_data.set10('HAVE_CL_CL_H', 1)
endif