aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2023-09-01 17:23:58 +0200
committerThomas White <taw@physics.org>2023-09-01 17:23:58 +0200
commit627bb2e3f6ab6f4d87e4f58f7378346b7f8ce683 (patch)
tree202dfadee04ac0f404190d5687c070d1f3eab383 /meson.build
parentd170ca538a234ea0de20722c5453d2cd7d4e0ef8 (diff)
Meson: Make Pandoc usage optional
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build20
1 files changed, 11 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index 172085c5..d9fae8aa 100644
--- a/meson.build
+++ b/meson.build
@@ -283,15 +283,17 @@ pandoc = find_program('pandoc', required: false)
pandoc_pages = ['adjust_detector.1.md']
-foreach page : pandoc_pages
- custom_target(page,
- input: join_paths('doc/man', page),
- output: '@BASENAME@',
- command: [pandoc, '@INPUT@','-o', '@OUTPUT@',
- '-s', '-f', 'markdown-smart', '-t', 'man'],
- install: true,
- install_dir: join_paths(get_option('mandir'), 'man1'))
-endforeach
+if pandoc.found()
+ foreach page : pandoc_pages
+ custom_target(page,
+ input: join_paths('doc/man', page),
+ output: '@BASENAME@',
+ command: [pandoc, '@INPUT@','-o', '@OUTPUT@',
+ '-s', '-f', 'markdown-smart', '-t', 'man'],
+ install: true,
+ install_dir: join_paths(get_option('mandir'), 'man1'))
+ endforeach
+endif
install_man(['doc/man/ambigator.1',
'doc/man/cell_explorer.1',